SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   Drupal Vendors:   drupal.org
Drupal Bugs Let Remote Users Access Certain Uploaded Files and Execute Arbitrary Code
SecurityTracker Alert ID:  1038781
SecurityTracker URL:  http://securitytracker.com/id/1038781
CVE Reference:   CVE-2017-6920, CVE-2017-6921, CVE-2017-6922   (Links to External Site)
Date:  Jun 23 2017
Impact:   Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Not specified, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 7.x, 8.x
Description:   Several vulnerabilities were reported in Drupal. A remote user can execute arbitrary code on the target system. A remote user can obtain certain uploaded files on the target system.

A remote user can send specially crafted data to trigger an object handling error in the PECL YAML parser and execute arbitrary code on the target system [CVE-2017-6920]. Versions 8.x are affected.

The file REST resource does not properly validate some fields when modifying files via PATCH request [CVE-2017-6921]. The impact was not specified. Systems with the RESTful Web Services (rest) module enabled are affected. Versions 8.x are affected.

A remote user can access files that have been uploaded by a different anonymous user into a private file system [CVE-2017-6922]. [Editor's note: This vulnerability is being actively exploited for SPAM purposes.]

Heine Deelstra of the Drupal Security team, Samuel Mortenson, Greg Knaddison of the Drupal Security team, Mori Sugimoto of the Drupal Security team, and iancawthorne reported these vulnerabilities.

Impact:   A remote user can execute arbitrary code on the target system.

A remote user can obtain certain uploaded files on the target system.

The impact of one vulnerability was not specified.

Solution:   The vendor has issued a fix (7.56, 8.3.4).

The vendor advisory is available at:

https://www.drupal.org/SA-CORE-2017-003

Vendor URL:  www.drupal.org/SA-CORE-2017-003 (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  https://www.drupal.org/SA-CORE-2017-003

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC