SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Wireshark Vendors:   Wireshark.org
Wireshark Multiple Dissector Bugs Lets Remote Users Deny Service
SecurityTracker Alert ID:  1038612
SecurityTracker URL:  http://securitytracker.com/id/1038612
CVE Reference:   CVE-2017-9343, CVE-2017-9344, CVE-2017-9345, CVE-2017-9346, CVE-2017-9347, CVE-2017-9348, CVE-2017-9349, CVE-2017-9350, CVE-2017-9351, CVE-2017-9352, CVE-2017-9353, CVE-2017-9354, CVE-2017-11411   (Links to External Site)
Updated:  Aug 3 2017
Original Entry Date:  Jun 5 2017
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.2.0 - 2.2.6, 2.0.0 - 2.0.12
Description:   Multiple vulnerabilities were reported in Wireshark. A remote user can cause denial of service conditions on the target system.

A remote user can send specially crafted data to cause the target dissector to enter an infinite loop and consume excessive CPU resources on the target system.

The Bazaar dissector is affected [CVE-2017-9352].

The SoulSeek dissector is affected [CVE-2017-9346].

The DNS dissector is affected [CVE-2017-9345].

The DICOM dissector is affected [CVE-2017-9349].

A remote user can send specially crafted data to cause the target dissector to crash.

The openSAFETY dissector is affected [CVE-2017-9350, CVE-2017-11411].

The Bluetooth L2CAP dissector is affected by a divide-by-zero error [CVE-2017-9344].

The MSNIP dissector is affected [CVE-2017-9343].

The ROS dissector is affected [CVE-2017-9347]. Versions 2.2.x are affected.

The RGMP dissector is affected [CVE-2017-9354].

The IPv6 dissector is affected [CVE-2017-9353]. Versions 2.2.x are affected.

A remote user can send specially crafted data to cause the target dissector to read past the end of a buffer and crash.

The DOF dissector is affected [CVE-2017-9348]. Versions 2.2.x are affected.

The DHCP dissector is affected [CVE-2017-9351].

The OSS-Fuzz project reported these vulnerabilities.

Impact:   A remote user can cause denial of service conditions on the target system.
Solution:   The vendor has issued a fix (2.0.13, 2.2.7).

The vendor advisories are available at:

https://www.wireshark.org/security/wnpa-sec-2017-22.html
https://www.wireshark.org/security/wnpa-sec-2017-23.html
https://www.wireshark.org/security/wnpa-sec-2017-24.html
https://www.wireshark.org/security/wnpa-sec-2017-25.html
https://www.wireshark.org/security/wnpa-sec-2017-26.html
https://www.wireshark.org/security/wnpa-sec-2017-27.html
https://www.wireshark.org/security/wnpa-sec-2017-28.html
https://www.wireshark.org/security/wnpa-sec-2017-29.html
https://www.wireshark.org/security/wnpa-sec-2017-30.html
https://www.wireshark.org/security/wnpa-sec-2017-31.html
https://www.wireshark.org/security/wnpa-sec-2017-32.html
https://www.wireshark.org/security/wnpa-sec-2017-33.html

Vendor URL:  www.wireshark.org/security/wnpa-sec-2017-22.html (Links to External Site)
Cause:   Access control error, Boundary error, Resource error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC