SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1038552
SecurityTracker URL:  http://securitytracker.com/id/1038552
CVE Reference:   CVE-2017-7494   (Links to External Site)
Date:  May 24 2017
Impact:   Execution of arbitrary code via network, Root access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 3.5.0 and after
Description:   A vulnerability was reported in Samba. A remote authenticated user can execute arbitrary code on the target system.

A remote authenticated user can upload a shared library to a writable share and then open a specially named pipe endpoint (containing a '/' character) cause the target system to execute the library with root privileges.

steelo reported this vulnerability.

Impact:   A remote authenticated user with write privileges on the target share can execute arbitrary code with root privileges on the target system.
Solution:   The vendor has issued a fix (4.4.14, 4.5.10, 4.6.4).

The vendor advisory is available at:

https://www.samba.org/samba/security/CVE-2017-7494.html

Vendor URL:  www.samba.org/samba/security/CVE-2017-7494.html (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 24 2017 (Ubuntu Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, 16.10, and 17.04.
May 24 2017 (Red Hat Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Red Hat has issued a fix for Red Hat Enterprise Linux 6 and 7.
May 24 2017 (Red Hat Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Red Hat has issued a fix for samba4 for Red Hat Enterprise Linux 6.
May 24 2017 (Red Hat Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Red Hat has issued a fix for samba3x for Red Hat Enterprise Linux 5.
May 24 2017 (Red Hat Issues Fix for Red Hat Gluster Storage) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Red Hat has issued a fix for Red Hat Gluster Storage for Red Hat Enterprise Linux.
May 25 2017 (Ubuntu Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Ubuntu has issued a fix for Ubuntu Linux 12.04 ESM.
May 26 2017 (Oracle Issues Fix for Oracle Linux) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Oracle has issued a fix for Oracle Linux 6 and 7.
May 26 2017 (CentOS Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
CentOS has issued a fix for CentOS 6 and 7.
May 29 2017 (QNAP Systems Issues Fix for QNAP Storage Devices) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
QNAP Systems has issued a fix for QNAP Storage Devices.
May 31 2017 (Oracle Issues Fix for Oracle Linux) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Oracle has issued a fix for Oracle Linux 5 for samba3x.
May 31 2017 (Cisco Issues Advisory for Cisco Prime Network Analysis Module) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Cisco has issued an advisory for Cisco Prime Network Analysis Module.
May 31 2017 (Cisco Issues Advisory for Cisco Video Surveillance Manager) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Cisco has issued an advisory for Cisco Video Surveillance Manager.
Jun 5 2017 (Red Hat Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
Red Hat has issued a fix for Red Hat Enterprise Linux 6.2, 6.4, 6.5, 6.6, 6.7, and 7.2.
Jun 9 2017 (HPE Issues Fix for HPE NonStop Server) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
HPE has issued a fix for HPE NonStop Server.
Jun 12 2017 (HPE Issues Fix) Samba smbd Named Pipe Validation Flaw Lets Remote Authenticated Users Execute Arbitrary Code on the Target System
HPE has issued mitigation instructions for HP-UX.



 Source Message Contents

Subject:  https://www.samba.org/samba/security/CVE-2017-7494.html

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC