SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Apache Archiva Vendors:   Apache Software Foundation
Apache Archiva Access Control Flaw at Several REST Endpoints Lets Remote Users Conduct Cross-Site Request Forgery Attacks
SecurityTracker Alert ID:  1038528
SecurityTracker URL:  http://securitytracker.com/id/1038528
CVE Reference:   CVE-2017-5657   (Links to External Site)
Updated:  May 19 2017
Original Entry Date:  May 19 2017
Impact:   Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.x, 2.0.0 - 2.2.1
Description:   A vulnerability was reported in Apache Archiva. A remote user can conduct cross-site request forgery attacks.

Several REST endpoints do not properly validate user-supplied requests. A remote user can create a specially crafted HTML page or URL that, when loaded by the target authenticated user, will take actions on the target interface acting as the target user.

Impact:   A remote user can take actions on the target system acting as the target authenticated user.
Solution:   The vendor has issued a fix (2.2.3).

The vendor advisory is available at:

http://archiva.apache.org/security.html#CVE-2017-5657

Vendor URL:  archiva.apache.org/security.html#CVE-2017-5657 (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Subject:  [oss-security] [SECURITY] CVE-2017-5657: Apache Archiva CSRF vulnerability for REST endpoints

CVE-2017-5657: Apache Archiva CSRF vulnerabilities for various REST endpoints

Severity: Important

Vendor:
The Apache Software Foundation

Versions Affected:
    Archiva 2.0.0 - 2.2.1
    The unsupported versions 1.x are also affected.  

Several REST service endpoints of Apache Archiva are not protected against 
Cross Site Request Forgery (CSRF) attacks. A malicious site opened in the same 
browser as the archiva site, may send HTML response that performs arbitrary 
actions on archiva services, with the same rights as the active archiva 
session (e.g. adminstrator rights).

Mitigation:
  All users are recommended to upgrade to Archiva 2.2.3 or higher, 
  where additional measures are taken to verify the origin of REST requests.

References:
http://archiva.apache.org/security.html#CVE-2017-5657

The newest Archiva version can be downloaded from:
http://archiva.apache.org/download.cgi



 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC