SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Security)  >   Network Security Services (NSS) Vendors:   Mozilla.org
(Oracle Issues Fix for Oracle Linux for Network Security Services (NSS)) Mozilla Firefox Multiple Bugs Let Remote Users Bypass Security Restrictions, Spoof URLs, Obtain Potentially Sensitive Information, Deny Service, and Execute Arbitrary Code
SecurityTracker Alert ID:  1038339
SecurityTracker URL:  http://securitytracker.com/id/1038339
CVE Reference:   CVE-2017-5461   (Links to External Site)
Date:  Apr 20 2017
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in Mozilla Firefox. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can obtain files on the target system. A remote user can spoof URLs. A remote user can conduct cross-site scripting attacks. Network Security Services (NSS) is affected.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A use-after-free memory error may occur in SMIL animation [CVE-2017-5433].

A use-after-free memory error may occur in transaction processing in the editor during design mode interactions [CVE-2017-5435].

An out-of-bounds memory write error may occur in the Graphite 2 library [CVE-2017-5436].

An out-of-bounds memory write error may occur in Base64 encoding in NSS [CVE-2017-5461].

A buffer overflow may occur in WebGL [CVE-2017-5459].

A use-after-free memory error may occur when redirecting focus handling [CVE-2017-5434].

A use-after-free memory error may occur during certain text input selection [CVE-2017-5432].

A use-after-free memory error may occur in frame selection [CVE-2017-5460].

A use-after-free memory error may occur in nsAutoPtr during XSLT processing [CVE-2017-5438].

A use-after-free memory error may occur in nsTArray Length() during XSLT processingn [CVE-2017-5439].

A use-after-free memory error may occur in txExecutionState destructor during XSLT processing [CVE-2017-5440].

A use-after-free memory error may occur with selection during scroll events [CVE-2017-5441].

A use-after-free memory error may occur in during style changes when manipulating DOM elements [CVE-2017-5442].

A memory corruption error may occur with accessibility and DOM manipulation [CVE-2017-5464].

An out-of-bounds memory write error may occur during BinHex decoding [CVE-2017-5443].

A buffer overflow may occur when parsing application/http-index-format content [CVE-2017-5444].

An out-of-bounds memory read error may occur in processing HTTP/2 DATA frames [CVE-2017-5446].

An out-of-bounds memory read error may occur in glyph processing [CVE-2017-5447].

An out-of-bounds memory read error may occur in ConvolvePixel [CVE-2017-5465].

An out-of-bounds memory write error may occur in ClearKeyDecryptor [CVE-2017-5448].

A remote user can escape the sandbox and read files on the target system via file picker [CVE-2017-5454].

A remote user can escape the sandbox via internal feed reader APIs and gain elevated privileges [CVE-2017-5455].

A remote user can escape the sandbox and read files on the target system via an IPC message [CVE-2017-5456].

A buffer overflow may occur in flex-generated code [CVE-2017-5469].

A remote user can read uninitialized values when parsing application/http-index-format content [CVE-2017-5445].

A crash during bidirectional unicode manipulation with CSS animations may allow code execution [CVE-2017-5449].

A memory corruption error may occur when drawing Skia content [CVE-2017-5467].

Other memory corruption errors may occur [CVE-2017-5429, CVE-2017-5430].

Some errors may occur in Libevent [CVE-2016-10195, CVE-2016-10196, CVE-2016-10197].

A remote user can inject static HTML into the RSS reader preview page [CVE-2017-5453].

A remote user can conduct cross-site scripting attacks when a user drags and drops a 'javascript:' URL into the addressbar [CVE-2017-5458].

An origin confusion error may occur when reloading isolated data:text/html URLs, allowing cross-site scripting attacks [CVE-2017-5466].

An incorrect ownership model of privateBrowsing information may occur via developer tools during debugging [CVE-2017-5468].

A remote user can spoof the address bar via Android intents [CVE-2017-5463]. Firefox for Android is affected.

A remote user can spoof the address bar during scrolling with editable content [CVE-2017-5452]. Firefox for Android is affected.

A remote user can spoof the address bar using javascript: URIs [CVE-2017-5450].

A remote user can spoof the address bar using the onblur event [CVE-2017-5451].

The Network Security Services (NSS) library may not properly generate Deterministic Random Bit Generator (DRBG) numbers [CVE-2017-5462].

Anonymous, Anonymous (via Trend Micro's Zero Day Initiative), Atte Kettunen, Bob Clary, Chamal De Silva, Chris Peterson, Christian Holler, Chun Han Hsiao, Daniel Veditz, David Baron, Haik Aftandilian, Haosheng Wang, Heather Miller of Google Skia team, Holger Fuhrmannek, Huzaifa Sidhpurwala, Ivan Fratric of Google Project Zero, Jon Coppeard,
Jordi Chancel, Jose Maria Acuna, Julian Hector, Kan-Ru Chen, Marcia Knous, Mats Palmgren, Milan Sreckovic, Muneaki Nishimura, Nicolas Gregoire, Nils, Paul Theriault, Petr Cerny, Philipp, Randell Jesup, Ronald Crane, Takeshi Terada, Tooru Fujisawa, Tyson Smith, Vladimir Klebanov, and Franziskus Kiefer reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can obtain files on the target system.

A remote user can spoof a URL.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with an arbitrary site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   Oracle has issued a fix for CVE-2017-5461 for Network Security Services (NSS).

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2017-1100.html

Vendor URL:  linux.oracle.com/errata/ELSA-2017-1100.html (Links to External Site)
Cause:   Access control error, Boundary error, Input validation error, Randomization error, State error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  7

Message History:   This archive entry is a follow-up to the message listed below.
Apr 20 2017 Mozilla Firefox Multiple Bugs Let Remote Users Bypass Security Restrictions, Spoof URLs, Obtain Potentially Sensitive Information, Deny Service, and Execute Arbitrary Code



 Source Message Contents

Date:  Thu, 20 Apr 2017 12:20:29 -0700
Subject:  [El-errata] ELSA-2017-1100 Critical: Oracle Linux 7 nss and nss-util security update

Oracle Linux Security Advisory ELSA-2017-1100

http://linux.oracle.com/errata/ELSA-2017-1100.html

The following updated rpms for Oracle Linux 7 have been uploaded to the 
Unbreakable Linux Network:

x86_64:
nss-3.28.4-1.0.0.1.el7_3.i686.rpm
nss-3.28.4-1.0.0.1.el7_3.x86_64.rpm
nss-devel-3.28.4-1.0.0.1.el7_3.i686.rpm
nss-devel-3.28.4-1.0.0.1.el7_3.x86_64.rpm
nss-pkcs11-devel-3.28.4-1.0.0.1.el7_3.i686.rpm
nss-pkcs11-devel-3.28.4-1.0.0.1.el7_3.x86_64.rpm
nss-sysinit-3.28.4-1.0.0.1.el7_3.x86_64.rpm
nss-tools-3.28.4-1.0.0.1.el7_3.x86_64.rpm
nss-util-3.28.4-1.0.el7_3.i686.rpm
nss-util-3.28.4-1.0.el7_3.x86_64.rpm
nss-util-devel-3.28.4-1.0.el7_3.i686.rpm
nss-util-devel-3.28.4-1.0.el7_3.x86_64.rpm


SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates/nss-3.28.4-1.0.0.1.el7_3.src.rpm
http://oss.oracle.com/ol7/SRPMS-updates/nss-util-3.28.4-1.0.el7_3.src.rpm



Description of changes:

nss
[3.28.4-1.0.0.1]
- Added nss-vendor.patch to change vendor

[3.28.4-1.0]
- Rebase to NSS 3.28.4

nss-util
[3.28.4-1.0]
- Rebase to nss-3.28.4 to accommodate base64 encoding issue


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC