SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Database)  >   MySQL Vendors:   MySQL.com, Oracle
MySQL Multiple Flaws Let Remote Authenticated and Local Users Modify Data, Remote and Local Users Deny Service, and Remote Authenticated Users Gain Elevated Privileges
SecurityTracker Alert ID:  1038287
SecurityTracker URL:  http://securitytracker.com/id/1038287
CVE Reference:   CVE-2017-3302, CVE-2017-3304, CVE-2017-3305, CVE-2017-3306, CVE-2017-3307, CVE-2017-3308, CVE-2017-3309, CVE-2017-3329, CVE-2017-3331, CVE-2017-3450, CVE-2017-3452, CVE-2017-3453, CVE-2017-3454, CVE-2017-3455, CVE-2017-3456, CVE-2017-3457, CVE-2017-3458, CVE-2017-3459, CVE-2017-3460, CVE-2017-3461, CVE-2017-3462, CVE-2017-3463, CVE-2017-3464, CVE-2017-3465, CVE-2017-3467, CVE-2017-3468, CVE-2017-3469, CVE-2017-3586, CVE-2017-3589, CVE-2017-3590, CVE-2017-3599, CVE-2017-3600   (Links to External Site)
Updated:  Apr 19 2017
Original Entry Date:  Apr 19 2017
Impact:   Denial of service via local system, Denial of service via network, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Multiple vulnerabilities were reported in MySQL. A remote user can access data on the target system. A remote or local user can cause denial of service conditions on the target system. A remote authenticated user can gain elevated privileges. A remote authenticated user can modify data on the target system. A remote authenticated or local user can modify data on the target system.

A remote authenticated user can exploit a flaw in the MySQL Enterprise Monitor component to access data, modify data, and partially deny service [CVE-2017-3306].

A remote authenticated user can exploit a flaw in the Server: DML component to cause denial of service conditions [CVE-2017-3308].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2017-3309].

A remote user can exploit a flaw in the Server: Memcached component to cause denial of service conditions [CVE-2017-3450].

A remote user can exploit a flaw in the Server: Pluggable Auth component to cause denial of service conditions [CVE-2017-3599].

A remote user can exploit a flaw in the Server: Thread Pooling component to cause denial of service conditions [CVE-2017-3329].

A remote authenticated user can exploit a flaw in the Client mysqldump component to gain elevated privileges [CVE-2017-3600].

A remote authenticated user can exploit a flaw in the Server: DML component to cause denial of service conditions [CVE-2017-3331].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2017-3452, CVE-2017-3453].

A remote authenticated user can exploit a flaw in the Connector/J component to partially access and partially modify data [CVE-2017-3586].

A remote authenticated user can exploit a flaw in the Server: InnoDB component to partially modify data and cause denial of service conditions [CVE-2017-3454].

A remote authenticated user can exploit a flaw in the Cluster: DD component to partially modify data and cause partial denial of service conditions [CVE-2017-3304].

A remote authenticated user can exploit a flaw in the Server: Security: Privileges component to partially access and partially modify data [CVE-2017-3455].

A remote authenticated user can exploit a flaw in the Server: C API component to access data [CVE-2017-3305].

A local user can exploit a flaw in the Server: C API component to cause denial of service conditions [CVE-2017-3302].

A remote authenticated user can exploit a flaw in the Server: Audit Plug-in component to cause denial of service conditions [CVE-2017-3460].

A remote authenticated user can exploit a flaw in the Server: DML component to cause denial of service conditions [CVE-2017-3456, CVE-2017-3457, CVE-2017-3458].

A remote authenticated user can exploit a flaw in the Server: Optimizer component to cause denial of service conditions [CVE-2017-3459].

A remote authenticated user can exploit a flaw in the Server: Security: Privileges component to cause denial of service conditions [CVE-2017-3461, CVE-2017-3462, CVE-2017-3463].

A remote authenticated user can exploit a flaw in the Server: DDL component to partially modify data [CVE-2017-3464].

A remote authenticated user can exploit a flaw in the Server: Security: Privileges component to partially modify data [CVE-2017-3465].

A remote user can exploit a flaw in the Server: C API component to partially access data [CVE-2017-3467].

A remote user can exploit a flaw in the Workbench: Security : Encryption component to partially access data [CVE-2017-3469].

A local user can exploit a flaw in the Connector/J component to partially modify data [CVE-2017-3589].

A local user can exploit a flaw in the Connector/Python component to partially modify data [CVE-2017-3590].

A remote authenticated user can exploit a flaw in the Monitoring: Server component to partially modify data and cause partial denial of service conditions [CVE-2017-3307].

A remote authenticated user can exploit a flaw in the Server: Security: Encryption component to partially modify data [CVE-2017-3468].

Zuozhi Fan formerly of Alibaba and Rodrigo Marcos of Secforce reported some of these vulnerabilities.

Impact:   A remote user can obtain data on the target system.

A remote authenticated user can modify data on the target system.

A local user can cause denial of service conditions on the target system.

A remote user can cause denial of service conditions.

A local user can modify data on the target system.

A remote authenticated user can gain elevated privileges on the target system.

Solution:   The vendor has issued a fix as part of the April 2017 Oracle Critical Patch Update.

The vendor advisory is available at:

http://www.oracle.com/technetwork/security-advisory/cpuapr2017-3236618.html

Vendor URL:  www.oracle.com/technetwork/security-advisory/cpuapr2017-3236618.html (Links to External Site)
Cause:   Not specified
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Apr 28 2017 (Ubuntu Issues Fix) MySQL Multiple Flaws Let Remote Authenticated and Local Users Modify Data, Remote and Local Users Deny Service, and Remote Authenticated Users Gain Elevated Privileges
Ubuntu has issued a fix for Ubuntu Linux 14.04 LTS, 16.04 LTS, 16.10, and 17.04.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC