SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
(CentOS Issues Fix) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
SecurityTracker Alert ID:  1038270
SecurityTracker URL:  http://securitytracker.com/id/1038270
CVE Reference:   CVE-2016-0736, CVE-2016-2161, CVE-2016-8743   (Links to External Site)
Date:  Apr 14 2017
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4.25
Description:   Multiple vulnerabilities were reported in Apache HTTPD. A remote user can access or modify session data. A remote user can cause the target service to crash. A remote user can conduct HTTP response splitting attacks.

The server does not strictly parse HTTP header data [CVE-2016-8743]. A remote user can submit a specially crafted URL to cause the target server to return a split response. A remote user can exploit this to spoof content on the target server, attempt to poison any intermediate web caches, or conduct cross-site scripting attacks.

A remote user can supply specially crafted data to mod_session_crypto to conduct a padding oracle attack and potentially access and modify session data [CVE-2016-0736].

A remote user can supply specially crafted data to mod_auth_digest to cause the target service to crash [CVE-2016-2161].

Alexander Neumann of RedTeam Pentesting, Maksim Malyutin, David Dennerline at IBM Security's X-Force Researchers, and Regis Leroy reported these vulnerabilities.

Impact:   A remote user can access or modify session data.

A remote user can cause the target service to crash.

A remote user can create a URL that, when loaded by the target user, will cause arbitrary content to be displayed.

A remote user may be able to poison any intermediate web caches with arbitrary content.

Solution:   CentOS has issued a fix.

x86_64:
3e941e4c2ee157ac7d6f020b3bfb4b2c2369d0a2bb3745534aa28e29925d9514 httpd-2.4.6-45.el7.centos.4.x86_64.rpm
fab0f1d0022353b090e1b288629d5ce8f5ecdf689f03958fb1171d03960f28b6 httpd-devel-2.4.6-45.el7.centos.4.x86_64.rpm
7ada864e1973c2d34dd46a5fc7557fcaf1c0f54c6313453c129331a29d56e862 httpd-manual-2.4.6-45.el7.centos.4.noarch.rpm
96889910d65624a1a3aa442eff188885f5bc42f8d76d888593297ac6e423e035 httpd-tools-2.4.6-45.el7.centos.4.x86_64.rpm
3e11f212393e9a117c8512e78e5e12ce42ee3408067d4715d745f6d041291b18 mod_ldap-2.4.6-45.el7.centos.4.x86_64.rpm
1ba540b53c222db6f0ac9eb1114387cf6f2d59647f2bdcb12b360f539f7f245e mod_proxy_html-2.4.6-45.el7.centos.4.x86_64.rpm
354357840c1362305c2a7fb085d55713082b9a3e88586d8348e100e4962da2ec mod_session-2.4.6-45.el7.centos.4.x86_64.rpm
a0d3a0af956f22c27ad04496d5fd456b3d55e869ca6c66dbbf2dab8437268450 mod_ssl-2.4.6-45.el7.centos.4.x86_64.rpm

Source:
f2f691a16d497ae89b7c1b3f5c8bebb559b5f86e10e52d0ce031225f7f695daf httpd-2.4.6-45.el7.centos.4.src.rpm

Cause:   Access control error, Authentication error, Input validation error
Underlying OS:  Linux (CentOS)
Underlying OS Comments:  7

Message History:   This archive entry is a follow-up to the message listed below.
Dec 21 2016 Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data



 Source Message Contents

Date:  Thu, 13 Apr 2017 10:59:52 +0000
Subject:  [CentOS-announce] CESA-2017:0906 Moderate CentOS 7 httpd Security Update


CentOS Errata and Security Advisory 2017:0906 Moderate

Upstream details at : https://rhn.redhat.com/errata/RHSA-2017-0906.html

The following updated files have been uploaded and are currently 
syncing to the mirrors: ( sha256sum Filename ) 

x86_64:
3e941e4c2ee157ac7d6f020b3bfb4b2c2369d0a2bb3745534aa28e29925d9514  httpd-2.4.6-45.el7.centos.4.x86_64.rpm
fab0f1d0022353b090e1b288629d5ce8f5ecdf689f03958fb1171d03960f28b6  httpd-devel-2.4.6-45.el7.centos.4.x86_64.rpm
7ada864e1973c2d34dd46a5fc7557fcaf1c0f54c6313453c129331a29d56e862  httpd-manual-2.4.6-45.el7.centos.4.noarch.rpm
96889910d65624a1a3aa442eff188885f5bc42f8d76d888593297ac6e423e035  httpd-tools-2.4.6-45.el7.centos.4.x86_64.rpm
3e11f212393e9a117c8512e78e5e12ce42ee3408067d4715d745f6d041291b18  mod_ldap-2.4.6-45.el7.centos.4.x86_64.rpm
1ba540b53c222db6f0ac9eb1114387cf6f2d59647f2bdcb12b360f539f7f245e  mod_proxy_html-2.4.6-45.el7.centos.4.x86_64.rpm
354357840c1362305c2a7fb085d55713082b9a3e88586d8348e100e4962da2ec  mod_session-2.4.6-45.el7.centos.4.x86_64.rpm
a0d3a0af956f22c27ad04496d5fd456b3d55e869ca6c66dbbf2dab8437268450  mod_ssl-2.4.6-45.el7.centos.4.x86_64.rpm

Source:
f2f691a16d497ae89b7c1b3f5c8bebb559b5f86e10e52d0ce031225f7f695daf  httpd-2.4.6-45.el7.centos.4.src.rpm



-- 
Johnny Hughes
CentOS Project { http://www.centos.org/ }
irc: hughesjr, #centos@irc.freenode.net
Twitter: @JohnnyCentOS

_______________________________________________
CentOS-announce mailing list
CentOS-announce@centos.org
https://lists.centos.org/mailman/listinfo/centos-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC