SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Server/CGI)  >   Apache Tomcat Vendors:   Apache Software Foundation
Apache Tomcat HTTP Connector Send File Processing Cache Error Lets Remote Users Obtain Potentially Sensitive Information on the Target System
SecurityTracker Alert ID:  1038219
SecurityTracker URL:  http://securitytracker.com/id/1038219
CVE Reference:   CVE-2017-5651   (Links to External Site)
Date:  Apr 11 2017
Impact:   Disclosure of system information, Disclosure of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.5.0 to 8.5.12, 9.0.0.M1 to 9.0.0.M18
Description:   A vulnerability was reported in Apache Tomcat. A remote user can obtain potentially sensitive information on the target system.

An error may occur in the HTTP connectors send file processing, causing the invoked Processor to be added to the cache twice. As a result, a remote user may view potentially sensitive information from the wrong response. Other unexpected errors may occur.

The original advisory is available at:

https://bz.apache.org/bugzilla/show_bug.cgi?id=60918

Andrew Garland reported this vulnerability [with security impact identified by the Tomcat security team].

Impact:   A remote user can obtain potentially sensitive information from a wrong response on the target system.
Solution:   The vendor has issued a fix (8.5.13, 9.0.0.M19).

The vendor advisories are available at:

http://tomcat.apache.org/security-8.html
http://tomcat.apache.org/security-9.html

Vendor URL:  tomcat.apache.org/security-9.html (Links to External Site)
Cause:   Access control error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Mon, 10 Apr 2017 20:14:50 +0100
Subject:  [SECURITY] CVE-2017-5651 Apache Tomcat Information Disclosure

CVE-2017-5651 Apache Tomcat Information Disclosure

Severity: Important

Vendor: The Apache Software Foundation

Versions Affected:
Apache Tomcat 9.0.0.M1 to 9.0.0.M18
Apache Tomcat 8.5.0 to 8.5.12
Apache Tomcat 8.0.x and earlier are not affected

Description:
The refactoring of the HTTP connectors for 8.5.x onwards, introduced a
regression in the send file processing. If the send file processing
completed quickly, it was possible for the Processor to be added to the
processor cache twice. This could result in the same Processor being
used for multiple requests which in turn could lead to unexpected errors
and/or response mix-up.

Mitigation:
Users of the affected versions should apply one of the following
mitigations:
- Upgrade to Apache Tomcat 9.0.0.M19 or later
- Upgrade to Apache Tomcat 8.5.13 or later

Credit:
This issue was reported publicly as Bug 60918 [1] and the security
implications identified by the Tomcat security team.

History:
2017-04-10 Original advisory

References:
[1] https://bz.apache.org/bugzilla/show_bug.cgi?id=60918
[2] http://tomcat.apache.org/security-9.html
[3] http://tomcat.apache.org/security-8.html

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC