SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   Moodle Vendors:   moodle.org
Moodle Bugs Let Remote Users Conduct Cross-Site Scripting Attacks and Remote Authenticated Users Obtain Usernames and Conduct SQL Injection Attacks
SecurityTracker Alert ID:  1038174
SecurityTracker URL:  http://securitytracker.com/id/1038174
CVE Reference:   CVE-2017-2641, CVE-2017-2643, CVE-2017-2644, CVE-2017-2645   (Links to External Site)
Date:  Apr 4 2017
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Several vulnerabilities were reported in Moodle. A remote authenticated user can inject SQL commands. A remote authenticated user can determine valid usernames on the target system. A remote user can conduct cross-site scripting attacks.

The web interface does not properly validate user-supplied input [CVE-2017-2641]. A remote authenticated user can supply a specially crafted parameter value to execute SQL commands on the underlying database.

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the Moodle software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Evidence of prior learning data is affected [CVE-2017-2644]. Versions 3.2.x and 3.1.x are affected.

Files attached to evidence of prior learning are affected [CVE-2017-2645]. Versions 3.2.x and 3.1.x are affected.

A remote authenticated user can exploit a flaw in the global search function to determine valid usernames on the target system [CVE-2017-2643]. Versions 3.2.x are affected.

wez3, Jaymark Pestano, Nadav Kavalerchik, and Netanel Rubin reported these vulnerabilities.

Impact:   A remote authenticated user can execute SQL commands on the underlying database.

A remote authenticated user can determine valid usernames on the target system.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the Moodle software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued a fix (2.7.19, 3.0.9, 3.1.5, 3.2.2).

The vendor advisory is available at:

https://moodle.org/security/

Vendor URL:  moodle.org/security/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC