SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   MantisBT Vendors:   mantisbt.sourceforge.net
MantisBT Input Validation Flaws in 'adm_config_report.php' and 'move_attachments_page.php' Let Remote Users Conduct Cross-Site Scripting Attacks
SecurityTracker Alert ID:  1038169
SecurityTracker URL:  http://securitytracker.com/id/1038169
CVE Reference:   CVE-2017-6973, CVE-2017-7241, CVE-2017-7309   (Links to External Site)
Date:  Mar 31 2017
Impact:   Disclosure of authentication information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   Several vulnerabilities were reported in MantisBT. A remote user can conduct cross-site scripting attacks.

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the MantisBT software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The 'action' parameter in 'adm_config_report.php' is affected [CVE-2017-6973]. Versions 1.3.0-rc.2 through 2.2.1 are affected.

The 'config_option' parameter in 'adm_config_report.php' is affected [CVE-2017-7309]. Versions 1.3.0-rc.2 through 2.2.2 are affected.

The 'type' parameter in 'move_attachments_page.php' is affected [CVE-2017-7241]. Versions 1.2.16 and after are affected. Systems with the admin tools directory removed are not affected.

Yelin and Zhangdongsheng from VenusTech reported these vulnerabilities.

Impact:   A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the MantisBT software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.
Solution:   The vendor has developed a fix (1.3.9, 2.1.3, 2.2.3, and 2.3.0; pending).

[Editor's note: The vulnerability assigned CVE-2017-6973 was corrected in versions 1.3.8 and 2.1.2.]

Vendor URL:  www.mantisbt.org/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC