SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Wireshark Vendors:   Wireshark.org
Wireshark Flaws in Multiple Dissectors Let Remote Users Cause the Target Service to Crash or Enter an Infinite Loop
SecurityTracker Alert ID:  1037960
SecurityTracker URL:  http://securitytracker.com/id/1037960
CVE Reference:   GENERIC-MAP-NOMATCH   (Links to External Site)
Date:  Mar 7 2017
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 2.0.0 to 2.0.10, 2.2.0 to 2.2.4
Description:   Multiple vulnerabilities were reported in Wireshark. A remote user can cause the target service to crash. A remote user can cause the target service to enter an infinite loop.

A remote user can send specially crafted data to cause the target service to crash.

The LDSS dissector is affected.

The NetScaler file parser is affected.

The K12xx file parser is affected.

A remote user can send specially crafted data to cause the target service to enter an infinite loop and consume excessive memory on the target system.

The RTMPT dissector is affected.

The WSP dissector is affected.

The STANAG 4607 dissector is affected.

The IAX2 dissector is affected.

The Netscaler file parser is affected.

Otto Airamo, Antti Levomaki, and Christian Jalio of Forcepoint, Chris Maixner, and Anil Kumar reported these vulnerabilities.

Impact:   A remote user can cause the target service to crash.

A remote user can consume excessive memory on the target system.

Solution:   The vendor has issued a fix (2.0.11, 2.2.5).

The vendor advisories are available at:

https://www.wireshark.org/security/wnpa-sec-2017-03.html
https://www.wireshark.org/security/wnpa-sec-2017-04.html
https://www.wireshark.org/security/wnpa-sec-2017-05.html
https://www.wireshark.org/security/wnpa-sec-2017-06.html
https://www.wireshark.org/security/wnpa-sec-2017-07.html
https://www.wireshark.org/security/wnpa-sec-2017-08.html
https://www.wireshark.org/security/wnpa-sec-2017-09.html
https://www.wireshark.org/security/wnpa-sec-2017-10.html
https://www.wireshark.org/security/wnpa-sec-2017-11.html

Vendor URL:  www.wireshark.org/security/wnpa-sec-2017-03.html (Links to External Site)
Cause:   Resource error, State error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC