SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Forum/Board/Portal)  >   WordPress Vendors:   wordpress.org
WordPress Bugs Let Remote Users Conduct Cross-Site Scripting and Cross-Site Request Forgery Attacks and Obtain Potentially Sensitive Information
SecurityTracker Alert ID:  1037591
SecurityTracker URL:  http://securitytracker.com/id/1037591
CVE Reference:   CVE-2017-5487, CVE-2017-5488, CVE-2017-5489, CVE-2017-5490, CVE-2017-5491, CVE-2017-5492, CVE-2017-5493   (Links to External Site)
Updated:  Jan 17 2017
Original Entry Date:  Jan 13 2017
Impact:   Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Execution of arbitrary code via network, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.7 and prior versions
Description:   Several vulnerabilities were reported in WordPress. A remote user can conduct cross-site request forgery attacks. A remote user can obtain potentially sensitive information on the target system. A remote user can conduct cross-site scripting attacks.

A remote user can send a specially crafted request to exploit a flaw in the REST API and view potentially sensitive user data on the target system [CVE-2017-5487].

The software does not properly filter HTML code from user-supplied input before displaying the input. A remote user can cause arbitrary scripting code to be executed by the target user's browser. The code will originate from the site running the WordPress software and will run in the security context of that site. As a result, the code will be able to access the target user's cookies (including authentication cookies), if any, associated with the site, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

The plugin name or version header on 'update-core.php' is affected [CVE-2017-5488].

The theme name fallback is affected [CVE-2017-5490].

A remote user can create a specially crafted HTML page or URL file that, when loaded by the target authenticated user, will take actions on the target interface acting as the target user. Uploaded Flash files are affected [CVE-2017-5489]. The accessibility mode of widget editing is also affected [CVE-2017-5493].

The post via email feature checks 'mail.example.com' if the system default settings are not changed [CVE-2017-5491].

The multisite activation key uses weak cryptography [CVE-2017-5493]. The impact was not specified.

Krogsgard, Chris Jean, Dominik Schilling of the WordPress Security Team, Abdullah Hussam, Mehmet Ince, John Blackbourn of the WordPress Security Team, Ronnie Skansing, and Jack reported these vulnerabilities.

Impact:   A remote user can take actions on the target system acting as the target authenticated user.

A remote user can obtain potentially sensitive information on the target system.

A remote user can access the target user's cookies (including authentication cookies), if any, associated with the site running the WordPress software, access data recently submitted by the target user via web form to the site, or take actions on the site acting as the target user.

Solution:   The vendor has issued a fix (4.7.1).

The vendor advisory is available at:

https://wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/

Vendor URL:  wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/ (Links to External Site)
Cause:   Access control error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC