SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Server/CGI)  >   Zend Server Vendors:   Zend
Zend Framework Input Validation Flaw in zend-mail Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1037539
SecurityTracker URL:  http://securitytracker.com/id/1037539
CVE Reference:   CVE-2016-10034   (Links to External Site)
Date:  Dec 31 2016
Impact:   Execution of arbitrary code via network, User access via network

Version(s): Framework 2.4.11
Description:   A vulnerability was reported in Zend Framework. A remote user can execute arbitrary code on the target system.

A remote user can supply specially crafted data that, when processed by the target zend-mail class to send email, will write data containing arbitrary code to a file on the target system that can later be executed. The code will run with the privileges of the target web service.

The original advisory is available at:

http://legalhackers.com/advisories/ZendFramework-Exploit-ZendMail-Remote-Code-Exec-CVE-2016-10034-Vuln.html

Dawid Golunski (@dawid_golunski) reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (Framework 2.4.11).

The vendor advisory is available at:

https://framework.zend.com/security/advisory/ZF2016-04

Vendor URL:  framework.zend.com/ (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   None.


 Source Message Contents

Date:  Fri, 30 Dec 2016 13:55:40 -0200
Subject:  Zend Framework / zend-mail < 2.4.11 Remote Code Execution (CVE-2016-10034)

Zend Framework < 2.4.11    Remote Code Execution (CVE-2016-10034)
zend-mail < 2.7.2

Discovered by Dawid Golunski (@dawid_golunski)
https://legalhackers.com

Desc:
An independent research uncovered a critical vulnerability in zend-mail, a
Zend Framework's component that could potentially be used by (unauthenticated)
remote attackers to achieve remote arbitrary code execution in the context
of the web server user and remotely compromise the target web application.

To exploit the vulnerability an attacker could target common website
components such as contact/feedback forms, registration forms, password
email resets and others that send out emails with the help of a vulnerable
version of the zend-mail class.

Full advisory / PoC exploit at:

http://legalhackers.com/advisories/ZendFramework-Exploit-ZendMail-Remote-Code-Exec-CVE-2016-10034-Vuln.html

Video / PoC:

https://legalhackers.com/videos/ZendFramework-Exploit-Remote-Code-Exec-Vuln-CVE-2016-10034-PoC.html

For updates, follow:

https://twitter.com/dawid_golunski



--
Regards,
Dawid Golunski
https://legalhackers.com
t: @dawid_golunski
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC