SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   PHPMailer Vendors:   phpmailer.sourceforge.net
PHPMailer Input Validation Flaw Lets Remote Users Execute Arbitrary Code on the Target System
SecurityTracker Alert ID:  1037533
SecurityTracker URL:  http://securitytracker.com/id/1037533
CVE Reference:   CVE-2016-10033, CVE-2016-10045   (Links to External Site)
Updated:  Dec 29 2016
Original Entry Date:  Dec 26 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 5.2.18 [separate vulnerability in 5.2.18/5.2.19]
Description:   A vulnerability was reported in PHPMailer. A remote user can execute arbitrary code on the target system.

A remote user can supply specially crafted data that, when processed by the target PHPMailer class to send email, will write data containing arbitrary code to a file on the target system that can later be executed. The code will run with the privileges of the target web service.

Several 3rd party products include the vulnerable code, including WordPress, Drupal, SugarCRM, and Joomla!.

Demonstration exploit code is available at:

https://github.com/opsxcq/exploit-CVE-2016-10033

The original advisory is available at:

https://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10033-Vuln.html

Dawid Golunski (@dawid_golunski) reported this vulnerability.

Impact:   A remote user can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (5.2.18).

[Editor's note: A vulnerability exists in the fixed version (5.2.18 and 5.2.19) and has been assigned CVE-2016-10045. A revised fix (5.2.20) is available. The original advisory is available at: https://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10045-Vuln-Patch-Bypass.html]

The vendor advisory is available at:

https://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md

Vendor URL:  github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md (Links to External Site)
Cause:   Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Dec 26 2016 (WordPress Issues Fix) PHPMailer Input Validation Flaw Lets Remote Users Execute Arbitrary Code on the Target System
WordPress has issued a fix.
Dec 26 2016 (Joomla! is Affected) PHPMailer Input Validation Flaw Lets Remote Users Execute Arbitrary Code on the Target System
Joomla! is affected.
Dec 26 2016 (Drupal Issues Advisory) PHPMailer Input Validation Flaw Lets Remote Users Execute Arbitrary Code on the Target System
Drupal has issued an advisory.



 Source Message Contents

Date:  Mon, 26 Dec 2016 00:21:07 -0200
Subject:  [oss-security] PHPMailer < 5.2.18 Remote Code Execution [CVE-2016-10033]

PHPMailer < 5.2.18 Remote Code Execution [CVE-2016-10033]

Severity: CRITICAL

Discovered by:
Dawid Golunski (@dawid_golunski)
https://legalhackers.com


PHPMailer
"Probably the world's most popular code for sending email from PHP!
Used by many open-source projects: WordPress, Drupal, 1CRM, SugarCRM, Yii,
Joomla! and many more"

Desc:
An independent research uncovered a critical vulnerability in PHPMailer that
could potentially be used by (unauthenticated) remote attackers to achieve
remote arbitrary code execution in the context of the web server user and
remotely compromise the target web application.
To exploit the vulnerability an attacker could target common website
components such as contact/feedback forms, registration forms, password
email resets and others that send out emails with the help of a vulnerable
version of the PHPMailer class.


Patching:
Responsibly disclosed to PHPMailer team.
They've released a critical security release.
If you are using an affected release update to the 5.2.18 security
release as advised at:
https://github.com/PHPMailer/PHPMailer/blob/master/changelog.md

Notes:
I know this is a bad timing and a short notice (for everyone probably ;)
I've spent most of my Christmas break working on this issue with
affected vendors.
This has been quite a rush as one of the vendors leaked excessive
information on this vulnerability at one point which could aid
potential attackers.

I've released a limited advisory at the link below:

https://legalhackers.com/advisories/PHPMailer-Exploit-Remote-Code-Exec-CVE-2016-10033-Vuln.html

This is to give people a chance to immediately patch or at least be
aware of the issue before we get closer to a working day/end of
holiday for affected users to act on this issue.

I'm planning to release the full advisory and a PoC exploit shortly so
that everyone is on the same page.

Upcoming video PoC:

https://legalhackers.com/videos/PHPMailer-Exploit-Remote-Code-Exec-Vuln-CVE-2016-10033-PoC.html


For updates follow:

https://twitter.com/dawid_golunski

I'll also send another email to the list once it is published.

For now,
Patch it now before someone else patches it for you (through a reverse shell ;)

-- 
Regards,
Dawid Golunski
https://legalhackers.com
t: @dawid_golunski
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC