SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Server/CGI)  >   Apache HTTPD Vendors:   Apache Software Foundation
Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
SecurityTracker Alert ID:  1037508
SecurityTracker URL:  http://securitytracker.com/id/1037508
CVE Reference:   CVE-2016-0736, CVE-2016-2161, CVE-2016-8743   (Links to External Site)
Date:  Dec 21 2016
Impact:   Denial of service via network, Disclosure of authentication information, Disclosure of system information, Disclosure of user information, Modification of system information, Modification of user information
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): prior to 2.4.25
Description:   Multiple vulnerabilities were reported in Apache HTTPD. A remote user can access or modify session data. A remote user can cause the target service to crash. A remote user can conduct HTTP response splitting attacks.

The server does not strictly parse HTTP header data [CVE-2016-8743]. A remote user can submit a specially crafted URL to cause the target server to return a split response. A remote user can exploit this to spoof content on the target server, attempt to poison any intermediate web caches, or conduct cross-site scripting attacks.

A remote user can supply specially crafted data to mod_session_crypto to conduct a padding oracle attack and potentially access and modify session data [CVE-2016-0736].

A remote user can supply specially crafted data to mod_auth_digest to cause the target service to crash [CVE-2016-2161].

Alexander Neumann of RedTeam Pentesting, Maksim Malyutin, David Dennerline at IBM Security's X-Force Researchers, and Regis Leroy reported these vulnerabilities.

Impact:   A remote user can access or modify session data.

A remote user can cause the target service to crash.

A remote user can create a URL that, when loaded by the target user, will cause arbitrary content to be displayed.

A remote user may be able to poison any intermediate web caches with arbitrary content.

Solution:   The vendor has issued a fix (2.4.25).

The vendor advisory is available at:

http://httpd.apache.org/security/vulnerabilities_24.html

Vendor URL:  httpd.apache.org/security/vulnerabilities_24.html (Links to External Site)
Cause:   Access control error, Authentication error, Input validation error
Underlying OS:  Linux (Any), UNIX (Any), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Feb 9 2017 (IBM Issues Fix for IBM HTTP Server (IHS)) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
IBM has issued a fix for IBM HTTP Server (IHS).
Mar 30 2017 (HPE Issues Fix) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
HPE has issued a fix for HP-UX 11.31.
Apr 14 2017 (Oracle Issues Fix for Oracle Linux) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
Oracle has issued a fix for Oracle Linux 7.
Apr 14 2017 (Red Hat Issues Fix) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
Red Hat has issued a fix for Red Hat Enterprise Linux 7.
Apr 14 2017 (CentOS Issues Fix) Apache HTTPD Multiple Flaws Let Remote Users Deny Service, Conduct HTTP Response Splitting Attacks, and Access and Modify Session Data
CentOS has issued a fix for CentOS 7.



 Source Message Contents

Date:  Tue, 20 Dec 2016 12:17:57 -0800
Subject:  [ANNOUNCE] Apache HTTP Server 2.4.25 Released

              Apache HTTP Server 2.4.25 Released

The Apache Software Foundation and the Apache HTTP Server Project
are pleased to announce the release of version 2.4.25 of the Apache
HTTP Server ("Apache").  This version of Apache is our latest GA
release of the new generation 2.4.x branch of Apache HTTPD and
represents fifteen years of innovation by the project, and is
recommended over all previous releases. This release of Apache is
a security, feature, and bug fix release, and addresses these
specific security defects as well as other fixes:

   CVE-2016-0736 (cve.mitre.org)
   mod_session_crypto: Authenticate the session data/cookie with a
   MAC (SipHash) to prevent deciphering or tampering with a padding
   oracle attack.

   CVE-2016-2161 (cve.mitre.org)
   mod_auth_digest: Prevent segfaults during client entry allocation
   when the shared memory space is exhausted.

   CVE-2016-5387 (cve.mitre.org)
   core: Mitigate [f]cgi "httpoxy" issues.

   CVE-2016-8740 (cve.mitre.org)
   mod_http2: Mitigate DoS memory exhaustion via endless
   CONTINUATION frames.

   CVE-2016-8743 (cve.mitre.org)
   Enforce HTTP request grammar corresponding to RFC7230 for request
   lines and request headers, to prevent response splitting and cache
   pollution by malicious clients or downstream proxies.

NOTE: Version 2.4.24 was not released.

We consider this release to be the best version of Apache available, and
encourage users of all prior versions to upgrade.

Apache HTTP Server 2.4.25 is available for download from:

   http://httpd.apache.org/download.cgi

Apache 2.4 offers numerous enhancements, improvements, and performance
boosts over the 2.2 codebase.  For an overview of new features
introduced since 2.4 please see:

   http://httpd.apache.org/docs/trunk/new_features_2_4.html

Please see the CHANGES_2.4 file, linked from the download page, for a
full list of changes. A condensed list, CHANGES_2.4.25 includes only
those changes introduced since the prior 2.4 release.  A summary of all
of the security vulnerabilities addressed in this and earlier releases
is available:

   http://httpd.apache.org/security/vulnerabilities_24.html

This release requires the Apache Portable Runtime (APR) version 1.5.x
and APR-Util version 1.5.x. The APR libraries must be upgraded for all
features of httpd to operate correctly.

This release builds on and extends the Apache 2.2 API.  Modules written
for Apache 2.2 will need to be recompiled in order to run with Apache
2.4, and require minimal or no source code changes.

   http://svn.apache.org/repos/asf/httpd/httpd/trunk/VERSIONING

When upgrading or installing this version of Apache, please bear in mind
that if you intend to use Apache with one of the threaded MPMs (other
than the Prefork MPM), you must ensure that any modules you will be
using (and the libraries they depend on) are thread-safe.

Please note that Apache Web Server Project will only provide maintenance
releases of the 2.2.x flavor through June of 2017, and will provide some
security patches beyond this date through at least December of 2017.
Minimal maintenance patches of 2.2.x are expected throughout this
period, and users are strongly encouraged to promptly complete their
transitions to the the 2.4.x flavor of httpd to benefit from a much
larger assortment of minor security and bug fixes as well as new
features.
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC