SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Xen Vendors:   Xen Project
(Oracle Issues Fix for Oracle Linux) Xen ioport Array Overflow Lets Local Administrative Users on a Guest System Gain Elevated Privileges on the QEMU Process
SecurityTracker Alert ID:  1037505
SecurityTracker URL:  http://securitytracker.com/id/1037505
CVE Reference:   CVE-2016-9637   (Links to External Site)
Date:  Dec 21 2016
Impact:   User access via local system
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in Xen. A local administrative user on the guest system can gain elevated privileges on the qemu process.

A local administrative user on the guest system can trigger an array overflow in ioport to gain qemu process privileges on the host system.

PV guests are not affected.

ARM systems are not affected.

yanghongke@huawei.com of the Huawei Security Test Team reported this vulnerability.

Impact:   A local administrative user on the guest system can gain QEMU process privileges.
Solution:   Oracle has issued a fix.

The Oracle Linux advisory is available at:

http://linux.oracle.com/errata/ELSA-2016-2963.html

Vendor URL:  linux.oracle.com/errata/ELSA-2016-2963.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Oracle)
Underlying OS Comments:  5

Message History:   This archive entry is a follow-up to the message listed below.
Dec 6 2016 Xen ioport Array Overflow Lets Local Administrative Users on a Guest System Gain Elevated Privileges on the QEMU Process



 Source Message Contents

Subject:  [El-errata] ELSA-2016-2963 Important: Oracle Linux 5 xen security update

Oracle Linux Security Advisory ELSA-2016-2963

http://linux.oracle.com/errata/ELSA-2016-2963.html

The following updated rpms for Oracle Linux 5 have been uploaded to the 
Unbreakable Linux Network:

i386:
xen-libs-3.0.3-148.el5_11.i386.rpm
xen-3.0.3-148.el5_11.i386.rpm
xen-devel-3.0.3-148.el5_11.i386.rpm

x86_64:
xen-libs-3.0.3-148.el5_11.i386.rpm
xen-libs-3.0.3-148.el5_11.x86_64.rpm
xen-3.0.3-148.el5_11.x86_64.rpm
xen-devel-3.0.3-148.el5_11.i386.rpm
xen-devel-3.0.3-148.el5_11.x86_64.rpm

ia64:
xen-libs-3.0.3-148.el5_11.ia64.rpm
xen-3.0.3-148.el5_11.ia64.rpm
xen-devel-3.0.3-148.el5_11.ia64.rpm


SRPMS:
http://oss.oracle.com/ol5/SRPMS-updates/xen-3.0.3-148.el5_11.src.rpm



Description of changes:

[3.0.3-148.el5_11]
- xen-qemu-ioport-array-overflow.patch [bz#1401521]
- Resolves: bz#1401521
   (CVE-2016-9637 xsa199 xen: qemu ioport array overflow (XSA-199) 
[rhel-5.11.z])


_______________________________________________
El-errata mailing list
El-errata@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/el-errata
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC