SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (File Transfer/Sharing)  >   Samba Vendors:   Samba.org
Samba Buffer Overflow in ndr_pull_dnsp_name() Lets Remote Authenticated Users Execute Arbitrary Code
SecurityTracker Alert ID:  1037493
SecurityTracker URL:  http://securitytracker.com/id/1037493
CVE Reference:   CVE-2016-2123   (Links to External Site)
Date:  Dec 19 2016
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 4.0.0 - 4.5.2
Description:   A vulnerability was reported in Samba. A remote authenticated user can execute arbitrary code on the target system.

A remote authenticated user on the local network can write specially crafted data to the Samba Active Directory ldb database dnsRecord attribute to trigger a buffer overflow in ndr_pull_dnsp_name() and execute arbitrary code on the target system.

Frederic Besler reported this vulnerability via Trend Micro's Zero Day Initiative.

Impact:   A remote authenticated user on the local network can execute arbitrary code on the target system.
Solution:   The vendor has issued a fix (4.3.13, 4.4.8, 4.5.3).

The vendor advisory is available at:

https://www.samba.org/samba/security/CVE-2016-2123.html

Vendor URL:  www.samba.org/samba/security/CVE-2016-2123.html (Links to External Site)
Cause:   Boundary error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Dec 19 2016 (Ubuntu Issues Fix) Samba Buffer Overflow in ndr_pull_dnsp_name() Lets Remote Authenticated Users Execute Arbitrary Code
Ubuntu has issued a fix for Ubuntu Linux 12.04 LTS, 14.04 LTS, 16.04 LTS, and 16.10.



 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC