SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (VoIP)  >   Asterisk Vendors:   Digium (Linux Support Services)
Asterisk Message Parsing Flaw in sdp_fmtp_get() Lets Remote Users Cause the Target Service to Crash
SecurityTracker Alert ID:  1037407
SecurityTracker URL:  http://securitytracker.com/id/1037407
CVE Reference:   CVE-2016-9937   (Links to External Site)
Updated:  Dec 13 2016
Original Entry Date:  Dec 8 2016
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 13.12.0 and after; 14.x
Description:   A vulnerability was reported in Asterisk. A remote user can cause the target service to crash.

A remote user can send a specially crafted Session Description Protocol (SDP) offer or SDP answer message with parameters separated using a space character and using the Opus codec to trigger a parsing error in sdp_fmtp_get() and cause the target service to enter a recursive loop and crash. The target system does not need to be configured for Opus.

Systems with guests enabled for chan_sip or anonymous enabled for chan_pjsip are affected by remote users without authentication.

jorgen reported this vulnerability.

Impact:   A remote user can cause the target service to crash.
Solution:   The vendor has issued a fix (13.13.1, 14.2.1).

The vendor advisory is available at:

http://downloads.digium.com/pub/security/AST-2016-008.html

Vendor URL:  downloads.digium.com/pub/security/AST-2016-008.html (Links to External Site)
Cause:   Input validation error, State error
Underlying OS:  Linux (Any), UNIX (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC