SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Web Browser)  >   Microsoft Internet Explorer Vendors:   Microsoft
Microsoft Internet Explorer Mulitple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1030715
SecurityTracker URL:  http://securitytracker.com/id/1030715
CVE Reference:   CVE-2014-2774, CVE-2014-2784, CVE-2014-2796, CVE-2014-2808, CVE-2014-2810, CVE-2014-2811, CVE-2014-2817, CVE-2014-2818, CVE-2014-2819, CVE-2014-2820, CVE-2014-2821, CVE-2014-2822, CVE-2014-2823, CVE-2014-2824, CVE-2014-2825, CVE-2014-2826, CVE-2014-2827, CVE-2014-4050, CVE-2014-4051, CVE-2014-4052, CVE-2014-4055, CVE-2014-4056, CVE-2014-4057, CVE-2014-4058, CVE-2014-4063, CVE-2014-4067, CVE-2014-6354   (Links to External Site)
Updated:  Dec 20 2014
Original Entry Date:  Aug 12 2014
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 6, 7, 8, 9, 10, 11
Description:   Multiple vulnerabilities were reported in Microsoft Internet Explorer. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create specially crafted content that, when loaded by the target user, will trigger a memory corruption error and execute arbitrary code on the target system [CVE-2014-2774, CVE-2014-2784, CVE-2014-2796, CVE-2014-2808, CVE-2014-2810, CVE-2014-2811, CVE-2014-2818, CVE-2014-2820, CVE-2014-2821, CVE-2014-2822, CVE-2014-2823, CVE-2014-2824, CVE-2014-2825, CVE-2014-2826, CVE-2014-2827, CVE-2014-4050, CVE-2014-4051, CVE-2014-4052, CVE-2014-4055, CVE-2014-4056, CVE-2014-4057, CVE-2014-4058, CVE-2014-4063, CVE-2014-4067, CVE-2014-6354]. The code will run with the privileges of the target user.

A remote user that can exploit another vulnerability can gain elevated privileges [CVE-2014-2817, CVE-2014-2819].

One of these privilege escalation vulnerabilities is being actively exploited.

AbdulAziz Hariri (via HP's Zero Day Initiative), Yujie Wen of Qihoo 360, Yuki Chen of Qihoo 360, Chen Zhang (demi6od) of NSFOCUS Security Team, IronRock (via VeriSign iDefense Labs), James Forshaw of Context Information Security, Zeguang Zhao of Team509 and Liang Chen of KeenTeam (@K33nTeam) (via HP's Zero Day Initiative), Arthur Gerkis (via HP's Zero Day Initiative), Bo Qu of Palo Alto Networks, Simon Zuckerbraun of HP's Zero Day Initiative, Omair (via HP's Zero Day Initiative), Peter 'corelanc0d3r' Van Eeckhoutte of Corelan (via HP's Zero Day Initiative), an anonymous researcher (via HP's Zero Day Initiative), Yuki Chen of Trend Micro (via HP's Zero Day Initiative), Sky (via HP's Zero Day Initiative), and Wei Wang of VulnHunt reported these vulnerabilities.

Impact:   A remote user can create content that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   The vendor has issued a fix.

A patch matrix is provided in the vendor's advisory.

A restart is required.

The Microsoft advisory is available at:

https://technet.microsoft.com/library/security/ms14-051

Vendor URL:  technet.microsoft.com/library/security/ms14-051 (Links to External Site)
Cause:   Access control error
Underlying OS:  Windows (Any)

Message History:   None.


 Source Message Contents



[Original Message Not Available for Viewing]


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2017, SecurityGlobal.net LLC