SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
(Red Hat Issues Fix) Adobe Reader Memory Corruption Flaw Lets Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024810
SecurityTracker URL:  http://securitytracker.com/id/1024810
CVE Reference:   CVE-2010-4091   (Links to External Site)
Date:  Dec 2 2010
Impact:   Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  Exploit Included:  Yes  
Version(s): 9.4 and prior 9.x versions
Description:   A vulnerability was reported in Adobe Reader. A remote user can cause arbitrary code to be executed on the target user's system.

A remote user can create a specially crafted PDF file that, when loaded by the target user, will trigger a memory corruption error and execute arbitrary code on the target system. The code will run with the privileges of the target user.

The vendor indicates that Adobe Acrobat is not affected.

scup at hushmail.com reported this vulnerability.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.
Solution:   Red Hat has issued a fix.

The Red Hat advisory is available at:

https://rhn.redhat.com/errata/RHSA-2010-0934.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb10-28.html (Links to External Site)
Cause:   Access control error
Underlying OS:   Linux (Red Hat Enterprise)

Message History:   This archive entry is a follow-up to the message listed below.
Nov 4 2010 Adobe Reader Memory Corruption Flaw Lets Remote Users Execute Arbitrary Code



 Source Message Contents

Date:  Wed, 1 Dec 2010 15:31:02 -0700
Subject:  [RHSA-2010:0934-01] Critical: acroread security update

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: acroread security update
Advisory ID:       RHSA-2010:0934-01
Product:           Red Hat Enterprise Linux Extras
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2010-0934.html
Issue date:        2010-12-01
CVE Names:         CVE-2010-3654 CVE-2010-4091 
=====================================================================

1. Summary:

Updated acroread packages that fix two security issues are now available
for Red Hat Enterprise Linux 4 Extras and Red Hat Enterprise Linux 5 and 6
Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

RHEL Desktop Supplementary (v. 5 client) - i386, x86_64
RHEL Supplementary (v. 5 server) - i386, x86_64
Red Hat Desktop version 4 Extras - x86_64
Red Hat Enterprise Linux AS version 4 Extras - x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - x86_64
Red Hat Enterprise Linux Server Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux WS version 4 Extras - x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 6) - i386, x86_64

3. Description:

Adobe Reader allows users to view and print documents in Portable Document
Format (PDF).

This update fixes two vulnerabilities in Adobe Reader. These
vulnerabilities are detailed on the Adobe security page APSB10-28, listed
in the References section. A specially-crafted PDF file could cause Adobe
Reader to crash or, potentially, execute arbitrary code as the user running
Adobe Reader when opened. (CVE-2010-3654, CVE-2010-4091)

All Adobe Reader users should install these updated packages. They contain
Adobe Reader version 9.4.1, which is not vulnerable to these issues. All
running instances of Adobe Reader must be restarted for the update to take
effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

647525 - CVE-2010-3654 acroread/flash-plugin: critical vulnerablility (APSA10-05, APSB10-26)
651133 - CVE-2010-4091 acroread: remote DoS or possible arbitrary code execution via EScript.api plugin

6. Package List:

Red Hat Enterprise Linux AS version 4 Extras:

x86_64:
acroread-9.4.1-1.el4.i386.rpm

Red Hat Desktop version 4 Extras:

x86_64:
acroread-9.4.1-1.el4.i386.rpm

Red Hat Enterprise Linux ES version 4 Extras:

x86_64:
acroread-9.4.1-1.el4.i386.rpm

Red Hat Enterprise Linux WS version 4 Extras:

x86_64:
acroread-9.4.1-1.el4.i386.rpm

RHEL Desktop Supplementary (v. 5 client):

i386:
acroread-9.4.1-1.el5.i386.rpm
acroread-plugin-9.4.1-1.el5.i386.rpm

x86_64:
acroread-9.4.1-1.el5.i386.rpm
acroread-plugin-9.4.1-1.el5.i386.rpm

RHEL Supplementary (v. 5 server):

i386:
acroread-9.4.1-1.el5.i386.rpm
acroread-plugin-9.4.1-1.el5.i386.rpm

x86_64:
acroread-9.4.1-1.el5.i386.rpm
acroread-plugin-9.4.1-1.el5.i386.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 6):

i386:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

x86_64:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

Red Hat Enterprise Linux Server Supplementary (v. 6):

i386:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

x86_64:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 6):

i386:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

x86_64:
acroread-9.4.1-1.el6.i686.rpm
acroread-plugin-9.4.1-1.el6.i686.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-3654.html
https://www.redhat.com/security/data/cve/CVE-2010-4091.html
http://www.redhat.com/security/updates/classification/#critical
http://www.adobe.com/support/security/bulletins/apsb10-28.html

8. Contact:

The Red Hat security contact is <secalert@redhat.com>.  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFM9syXXlSAg2UNWIIRAnloAJ9DN6v8UQKsBQ5EEfrMC4rb+zJbIwCfVyPA
3FQyYWcmbZ2ULjCk+vJnS4Y=
=3cTK
-----END PGP SIGNATURE-----


--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC