SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
Adobe Reader and Acrobat Multiple Flaws Let Remote Users Execute Arbitrary Code
SecurityTracker Alert ID:  1024159
SecurityTracker URL:  http://securitytracker.com/id/1024159
CVE Reference:   CVE-2010-1240, CVE-2010-1285, CVE-2010-1295, CVE-2010-2168, CVE-2010-2201, CVE-2010-2202, CVE-2010-2203, CVE-2010-2204, CVE-2010-2205, CVE-2010-2206, CVE-2010-2207, CVE-2010-2208   (Links to External Site)
Updated:  Aug 20 2010
Original Entry Date:  Jun 29 2010
Impact:   Denial of service via network, Execution of arbitrary code via network, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 8.2.2, and prior 8.x versions; 9.3.2 and prior 9.x versions
Description:   A vulnerability was reported in Adobe Reader and Adobe Acrobat. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions.

A remote user can create specially crafted content that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

A social engineering attack can lead to code execution [CVE-2010-1240].

Several invalid pointer flaws can cause code execution [CVE-2010-1285, CVE-2010-2168, CVE-2010-2201].

Several memory corruption flaws can cause code execution [CVE-2010-1295, CVE-2010-2202, CVE-2010-2207, CVE-2010-2209, CVE-2010-2210, CVE-2010-2211, CVE-2010-2212].

A memory corruption flaw affecting only UNIX-based systems can cause code execution [CVE-2010-2203].

A remote user can cause denial of service conditions [CVE-2010-2204].

An uninitialized memory flaw can cause code execution [CVE-2010-2205].

An array-indexing error can cause [CVE-2010-2206].

A deleted heap object deference flaw can cause code execution [CVE-2010-2208].

Microsoft Vulnerability Research (MSVR), Nicolas Joly of VUPEN Vulnerability Research Team, Didier Stevens, Philippe Lagadec of NATO C3 Agency, an anonymous researcher via TippingPoint's Zero Day Initiative, James Quirk of Los Alamos, New Mexico, Gjoko Krstic of Zero Science Lab, Alin Rad Pop of Secunia Research, Carsten Eiram of Secunia Research, and Tavis Ormandy of the Google Security Team reported these vulnerabilities.

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code on the target user's system.

A remote user can cause denial of service conditions.

Solution:   The vendor has issued a fix (8.2.3, 9.3.3).

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb10-15.html

On August 19, 2010, the vendor issued an additional fix (8.2.4, 9.3.3) for CVE-2010-1240. The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb10-17.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb10-15.html (Links to External Site)
Cause:   Access control error, Boundary error, State error
Underlying OS:   Linux (Any), UNIX (OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jun 30 2010 (Red Hat Issues Fix) Adobe Reader and Acrobat Multiple Flaws Let Remote Users Execute Arbitrary Code   (bugzilla@redhat.com)
Red Hat has issued a fix for Red Hat Enterprise Linux 4 and 5.



 Source Message Contents

Date:  Tue, 29 Jun 2010 19:09:40 +0000
Subject:  Adobe Reader and Adobe Acrobat


Vulnerability identifier: APSB10-15

CVE numbers: CVE-2010-1240, CVE-2010-1285, CVE-2010-1295, 
CVE-2010-2168, CVE-2010-2201, CVE-2010-2202, CVE-2010-2203, CVE-2010-2204, 
CVE-2010-2205, CVE-2010-2206, CVE-2010-2207, CVE-2010-2208, CVE-2010-2209, 
CVE-2010-2210, CVE-2010-2211, CVE-2010-2212
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC