SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
Adobe Acrobat and Adobe Reader Flaws Lets Remote Users Execute Arbitrary Code and Deny Service
SecurityTracker Alert ID:  1023007
SecurityTracker URL:  http://securitytracker.com/id/1023007
CVE Reference:   CVE-2009-2564, CVE-2009-2979, CVE-2009-2980, CVE-2009-2981, CVE-2009-2982, CVE-2009-2983, CVE-2009-2984, CVE-2009-2985, CVE-2009-2986, CVE-2009-2987, CVE-2009-2988, CVE-2009-2989, CVE-2009-2990, CVE-2009-2991, CVE-2009-2992, CVE-2009-2993, CVE-2009-2994, CVE-2009-2995, CVE-2009-2996, CVE-2009-2997, CVE-2009-2998, CVE-2009-3431, CVE-2009-3458, CVE-2009-3460, CVE-2009-3461, CVE-2009-3462   (Links to External Site)
Updated:  Oct 13 2009
Original Entry Date:  Oct 13 2009
Impact:   Execution of arbitrary code via network, User access via local system, User access via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 9.1.3 and prior versions; also 7.1 prior to 7.1.4, 8.1 prior to 8.1.7
Description:   Multiple vulnerabilities were reported in Adobe Acrobat and Adobe Reader. A remote user can cause arbitrary code to be executed on the target user's system. A remote user can cause denial of service conditions on the target user's system. A local user can gain elevated privileges.

A remote user can create a specially crafted file that, when loaded by the target user, will execute arbitrary code on the target system. The code will run with the privileges of the target user.

The following vulnerabilities may permit code execution:

- memory corruption [CVE-2009-2985]
- heap overflows [CVE-2009-2986]
- invalid array index flaw [CVE-2009-2990], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- Mozilla plug-in flaw [CVE-2009-2991], fixed in the Adobe Reader and Acrobat 8.1.7 updates
- input validation flaws [CVE-2009-2993]
- buffer overflow [CVE-2009-2994]
- heap overflow [CVE-2009-2997]
- input validation [CVE-2009-2998]
- input validation [CVE-2009-3458]
- memory corruption in Acrobat but not Adobe Reader [CVE-2009-3460], fixed in the Acrobat 9.2 and 8.1.7 updates
- integer overflow in Acrobat but not Adobe Reader [CVE-2009-2989], fixed in the Acrobat 9.2 and 8.1.7 updates

The following vulnerabilities permit denial of service and some may permit code execution:

- memory corruption [CVE-2009-2983], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- integer overflow [CVE-2009-2980]
- memory corruption [CVE-2009-2996]
- format bug when running in Debug mode on UNIX [CVE-2009-3462]
- image decoder flaw in Acrobat but not Adobe Reader [CVE-2009-2984], fixed in the Acrobat 9.2 update.
- input validation that may allow a bypass of Trust Manager restrictions [CVE-2009-2981].
- an unspecified flaw in the file extension security controls that affects Acrobat versions 9.x [CVE-2009-3461].
- a certificate flaw [CVE-2009-2982], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a stack overflow [CVE-2009-3431], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a flaw in XMP-XML entity expansion [CVE-2009-2979], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates
- a flaw in the ActiveX control, affecting Windows-based systems [CVE-2009-2987].
- input validation [CVE-2009-2988]
- input validation in the ActiveX control, affecting Windows-based systems [CVE-2009-2992], fixed in the Adobe Reader and Acrobat 9.2 and 8.1.7 updates.
- integer overflow in Acrobat but not Adobe Reader [CVE-2009-2995].
- unspecified flaw in a third party web download product that may allow a local user to gain elevated privileges [CVE-2009-2564].

The following researchers reported these vulnerabilities:

Didier Stevens (CVE-2009-2979); Drew Yao of Apple Product Security (CVE-2009-2980); Stefano Di Paola of Minded Security (CVE-2009-2981); Guillaume Delugr and Fr d ric Raynal of SOGETI ESEC (CVE-2009-2982, CVE-2009-3461, CVE-2009-3462); SkyLined of Google Inc. (CVE-2009-2983); Tavis Ormandy, Google Security Team (CVE-2009-2984); An anonymous researcher via TippingPoint (CVE-2009-2985); Will Dormann, CERT (CVE-2009-2986); Zhenhua Liu and Xiaopeng Zhang of Fortinet's FortiGuard Global Security Research Team (CVE-2009-2987, CVE-2009-2988, CVE-2009-2996); Tielei Wang from ICST-ERCIS (Engineering Research Center of Info Security, Institute of Computer Science & Technology, Peking University / China) (CVE-2009-2989, CVE-2009-2995); Dionysus Blazakis via iDefense (CVE-2009-2990); Elazar Broad via iDefense (CVE-2009-2991); David Soldera of Next Generation Security Software (CVE-2009-2992); IOActive (CVE-2009-2993); Felipe Andres Manzano via iSIGHT Partners (CVE-2009-2994); Nicolas Joly of VUPEN Security (CVE-2009-2997, CVE-2009-2998, CVE-2009-3458); Haifei Li of Fortinet's FortiGuard Global Security Research Team (CVE-2009-3460).

Impact:   A remote user can create a file that, when loaded by the target user, will execute arbitrary code or cause denial of service conditions on the target user's system.

A local user may be able to obtain elevated privileges.

Solution:   The vendor has issued a fix (7.1.4, 8.1.7, 9.2).

The vendor's advisory is available at:

http://www.adobe.com/support/security/bulletins/apsb09-15.html

Vendor URL:  www.adobe.com/support/security/bulletins/apsb09-15.html (Links to External Site)
Cause:   Access control error, Boundary error, Not specified
Underlying OS:   Linux (Any), UNIX (OS X), UNIX (Solaris - SunOS), Windows (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Oct 14 2009 (Red Hat Issues Fix) Adobe Acrobat and Adobe Reader Flaws Lets Remote Users Execute Arbitrary Code and Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux Extras 3, 4, and 5.



 Source Message Contents

Date:  Tue, 13 Oct 2009 14:47:14 -0400
Subject:  Adobe Acrobat / Adobe Reader


http://www.adobe.com/support/security/bulletins/apsb09-15.html

Security Updates Available for Adobe Reader and Acrobat

APSB09-15

CVE numbers: 

CVE-2007-0045
CVE-2007-0048
CVE-2009-2564
CVE-2009-2979
CVE-2009-2980
CVE-2009-2981
CVE-2009-2982
CVE-2009-2983
CVE-2009-2984
CVE-2009-2985
CVE-2009-2986
CVE-2009-2987
CVE-2009-2988
CVE-2009-2989
CVE-2009-2990
CVE-2009-2991
CVE-2009-2992
CVE-2009-2993
CVE-2009-2994
CVE-2009-2995
CVE-2009-2996
CVE-2009-2997
CVE-2009-2998
CVE-2009-3431
CVE-2009-3458
CVE-2009-3459
CVE-2009-3460
CVE-2009-3461
CVE-2009-3462

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC