SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Adobe Acrobat/Reader Vendors:   Adobe Systems Incorporated
Adobe Acrobat Temporary File Race Condition in 'acroread' Wrapper Script Lets Local Users Gain Elevated Privileges
SecurityTracker Alert ID:  1019539
SecurityTracker URL:  http://securitytracker.com/id/1019539
CVE Reference:   CVE-2008-0883   (Links to External Site)
Updated:  Mar 11 2008
Original Entry Date:  Mar 4 2008
Impact:   Execution of arbitrary code via local system, Modification of system information, Modification of user information, User access via local system
Vendor Confirmed:  Yes  
Version(s): 8.1.2
Description:   A vulnerability was reported in Adobe Acrobat Reader for Linux. A local user can obtain elevated privileges on the target system.

The "acroread" wrapper script uses unsafe temporary files (in '/tmp') when processing SSL certificates. A local user can gain elevated privileges.

SUSE reported this vulnerability.

Impact:   A local user can modify files on the target system to gain elevated privileges on the target system.
Solution:   No solution was available at the time of this entry. The vendor plans to issue a fix.

The vendor's advisory is available at:

http://www.adobe.com/support/security/advisories/apsa08-02.html

Vendor URL:  www.adobe.com/support/security/advisories/apsa08-02.html (Links to External Site)
Cause:   Access control error, State error
Underlying OS:   Linux (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
Jul 21 2008 (Red Hat Issues Fix) Adobe Acrobat Temporary File Race Condition in 'acroread' Wrapper Script Lets Local Users Gain Elevated Privileges   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 3, 4, and 5.
Aug 4 2008 (Sun Issues Advisory) Adobe Acrobat Temporary File Race Condition in 'acroread' Wrapper Script Lets Local Users Gain Elevated Privileges
Sun has issued an advisory for Solaris 10.



 Source Message Contents

Date:  Tue, 4 Mar 2008 16:14:33 -0500
Subject:  Adobe Acrobat / Adobe Reader


Adobe Acrobat Reader 8.1.2 contained a /tmp race in its "acroread"
wrapper script in the SSL certificate handling. (CVE-2008-0883) 
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC