SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   Ruby Vendors:   Matsumoto, Yukihiro
Ruby MIME Parsing Bug in cgi.rb Lets Remote Users Deny Service
SecurityTracker Alert ID:  1017363
SecurityTracker URL:  http://securitytracker.com/id/1017363
CVE Reference:   CVE-2006-6303   (Links to External Site)
Date:  Dec 11 2006
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  
Version(s): 1.8.5 and prior versions
Description:   A vulnerability was reported in Ruby. A remote user can cause denial of service conditions.

A remote user can send a specially crafted HTTP request for an application that uses the 'cgi.rb' CGI library to cause the target application to enter an infinite loop and consume excessive CPU resources.

Impact:   A remote user can cause denial of service conditions.
Solution:   The vendor has issued a fixed version (1.8.5-p2), available at:

http://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.5-p2.tar.gz

The vendor's advisory is available at:

http://www.ruby-lang.org/en/news/2006/12/04/another-dos-vulnerability-in-cgi-library/

Vendor URL:  www.ruby-lang.org/en/news/2006/12/04/another-dos-vulnerability-in-cgi-library/ (Links to External Site)
Cause:   State error
Underlying OS:   Linux (Any), UNIX (Any)

Message History:   This archive entry has one or more follow-up message(s) listed below.
May 25 2007 (Apple Issues Fix) Ruby MIME Parsing Bug in cgi.rb Lets Remote Users Deny Service   (Apple Product Security <product-security-noreply@lists.apple.com>)
Apple has released a fix for Mac OS X.
Nov 13 2007 (Red Hat Issues Fix) Ruby MIME Parsing Bug in cgi.rb Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 4.
Jul 14 2008 (Red Hat Issues Fix) Ruby MIME Parsing Bug in cgi.rb Lets Remote Users Deny Service   (bugzilla@redhat.com)
Red Hat has released a fix for Red Hat Enterprise Linux 2.1 and 3.



 Source Message Contents

Date:  Mon, 11 Dec 2006 08:40:47 -0500
Subject:  Ruby


http://www.ruby-lang.org/en/news/2006/12/04/another-dos-vulnerability-in-cgi-library/

CVE-2006-6303
 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC