SecurityTracker.com
Keep Track of the Latest Vulnerabilities
with SecurityTracker!
    Home    |    View Topics    |    Search    |    Contact Us    |   

SecurityTracker
Archives


 
Sign Up
Sign Up for Your FREE Weekly SecurityTracker E-mail Alert Summary
Instant Alerts
Buy our Premium Vulnerability Notification Service to receive customized, instant alerts
Affiliates
Put SecurityTracker Vulnerability Alerts on Your Web Site -- It's Free!
Partners
Become a Partner and License Our Database or Notification Service
Report a Bug
Report a vulnerability that you have found to SecurityTracker
bugs
@
securitytracker.com






Category:   Application (Generic)  >   nfs-utils Vendors:   nfs.sourceforge.net
(Gentoo Issues Fix for nfs-utils) rpc.statd SIGPIPE Error Lets Remote Users Shutdown the Process
SecurityTracker Alert ID:  1012502
SecurityTracker URL:  http://securitytracker.com/id/1012502
CVE Reference:   CAN-2004-1014   (Links to External Site)
Date:  Dec 14 2004
Impact:   Denial of service via network
Fix Available:  Yes  Vendor Confirmed:  Yes  

Description:   A vulnerability was reported in 'rpc.statd'. A remote user can cause denial of service conditions. nfs-utils is affected.

Several vendors reported a vulnerability in the NFS statd server. The rpc.statd process does not ignore the SIGPIPE signal. As a result, a remote process can prematurely terminate the TCP connection to trigger the signal and cause the process to shutdown.

SGI developers are credited with discovering this flaw.

Impact:   A remote user can cause 'rpc.statd' to shutdown.
Solution:   Gentoo has released a fix for nfs-utils (which is affected by the rpc vulnerability) and indicates that all nfs-utils users should upgarde to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-fs/nfs-utils-1.0.6-r6"

Vendor URL:  nfs.sourceforge.net/ (Links to External Site)
Cause:   State error
Underlying OS:   Linux (Gentoo)

Message History:   This archive entry is a follow-up to the message listed below.
Dec 7 2004 rpc.statd SIGPIPE Error Lets Remote Users Shutdown the Process



 Source Message Contents

Date:  Mon, 13 Dec 2004 22:54:15 -0500
Subject:  [gentoo-announce] [ GLSA 200412-08 ] nfs-utils: Multiple remote vulnerabilities



--0F1p//8PRICkK4MW
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200412-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: nfs-utils: Multiple remote vulnerabilities
      Date: December 14, 2004
      Bugs: #72113
        ID: 200412-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in nfs-utils that could
lead to a Denial of Service, or the execution of arbitrary code.

Background
==========

nfs-utils is a package containing the client and daemon implementations
for the NFS protocol.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  net-fs/nfs-utils     < 1.0.6-r6                       >= 1.0.6-r6

Description
===========

Arjan van de Ven has discovered a buffer overflow on 64-bit
architectures in 'rquota_server.c' of nfs-utils (CAN-2004-0946). A
remotely exploitable flaw on all architectures also exists in the
'statd.c' file of nfs-utils (CAN-2004-1014), which can be triggered by
a mishandled SIGPIPE.

Impact
======

A remote attacker could potentially cause a Denial of Service, or even
execute arbitrary code (64-bit architectures only) on a remote NFS
server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All nfs-utils users should upgarde to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-fs/nfs-utils-1.0.6-r6"

References
==========

  [ 1 ] CAN-2004-0946
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0946
  [ 2 ] CAN-2004-1014
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-1014

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200412-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--0F1p//8PRICkK4MW
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFBvmPnRsm3eDkOu7kRAqlRAJ9BR86p1TunEKX64yQXDt4M3XC3XgCfeD40
t+RfKzPpLeJAszawTXxJX6k=
=WVyK
-----END PGP SIGNATURE-----

--0F1p//8PRICkK4MW--

 
 


Go to the Top of This SecurityTracker Archive Page





Home   |    View Topics   |    Search   |    Contact Us

Copyright 2014, SecurityGlobal.net LLC